composer 常见问题处理

  • Jesse
  • 2019-09-04 10:20:29
  • 83
此文章为收集 composer 常见问题,后续会不断更新。

1.提示 版本 与 composer.json 不符

报错: Your requirements could not be resolved to an installable set of packages

解决办法1:

--ignore-platform-reqs

解决办法2:

"minimum-stability" : "dev",
"prefer-stable" : true

2.解决使用 Composer 的时候提示输入 Token

进入 https://github.com/settings/tokens 点击 「Generate new token」 新建一个 Token,选择默认新建就行,然后就会得到一个 Token,然后输入这个值就 OK 了

3.解决使用 composer 的时候错误 file could not be downloaded

composer config secure-http false

4.解决作者未发布版本 (Could not find a version of package)

composer require shark/simple_html_dom:dev-master

5.修改镜像源后,需刷新 composer.lock文件

composer update nothing

composer update --lock

--lock: 只升级 lock 文件的哈希以消除 lock 文件过期的警告。

6.清空本地缓存

composer clear-cache

本文出自 ShowCj,转载时请注明出处及相应链接。